Announcement

Collapse
No announcement yet.

speedo and headlight issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • speedo and headlight issue

    Hi there. I have a Honda Z50j1 and the speedo and headlight do not work. It has worked fine up until recently.
    Does anyone have any ideas as to what the problem could be or where I can find a repairer in Sydney please?

  • #2
    Is the bulb blown? Quite common with these because the batteries get old and can't absorb the extra voltage.
    Life is too short for cheap carbs...

    Comment


    • #3
      Thanks for your reply. the battery could be dodgy as I have had to charge it several times and may have blown the bulb. Would that also affect the speedo?

      Comment


      • #4
        Yep, these old wiring systems aren't great.
        Life is too short for cheap carbs...

        Comment


        • #5
          Originally posted by Terrie View Post
          Thanks for your reply. the battery could be dodgy as I have had to charge it several times and may have blown the bulb. Would that also affect the speedo?
          Usually find if one globe blows and you persist with it, the extra charge blows others.
          Once I thought I was wrong, I was mistaken

          Comment


          • #6
            Do u meant the speedo itself or the speedo light? May be check if speedo cable has came loose inside the headlight if u meant speedo not moving.
            still learning.....

            Comment

            Working...
            X